509318396
Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­Â�Â­
<!DOCTYPE html>
<html>
3

  \A  ã               @   s&   d dl mZ dgZG dd„ deƒZdS )é    )ÚIntEnumÚ
HTTPStatusc               @   sþ   e Zd ZdZd£dd„Zd¤Zd¥Zd¦Zd§Zd¨Z	d©Z
dªZd«Zd¬Zd­Zd®Zd¯Zd°Zd±Zd²Zd³Zd´ZdµZd¶Zd·Zd¸Zd¹ZdºZd»Zd¼Zd½Zd¾Zd¿Z dÀZ!dÁZ"dÂZ#dÃZ$dÄZ%dÅZ&dÆZ'dÇZ(dÈZ)dÉZ*dÊZ+dËZ,dÌZ-dÍZ.dÎZ/dÏZ0dÐZ1dÑZ2dÒZ3dÓZ4dÔZ5dÕZ6dÖZ7d×Z8dØZ9dÙZ:dÚZ;dÛZ<dÜZ=d¢S )Ýr   a  HTTP status codes and reason phrases

    Status codes from the following RFCs are all observed:

        * RFC 7231: Hypertext Transfer Protocol (HTTP/1.1), obsoletes 2616
        * RFC 6585: Additional HTTP Status Codes
        * RFC 3229: Delta encoding in HTTP
        * RFC 4918: HTTP Extensions for WebDAV, obsoletes 2518
        * RFC 5842: Binding Extensions to WebDAV
        * RFC 7238: Permanent Redirect
        * RFC 2295: Transparent Content Negotiation in HTTP
        * RFC 2774: An HTTP Extension Framework
    Ú c             C   s"   t j| |ƒ}||_||_||_|S )N)ÚintÚ__new__Ú_value_ÚphraseÚdescription)ÚclsÚvaluer   r	   Úobj© r   ú%/usr/lib64/python3.6/http/__init__.pyr      s
    zHTTPStatus.__new__éd   ÚContinueú!Request received, please continueée   úSwitching Protocolsú.Switching to new protocol; obey Upgrade headeréf   Ú
ProcessingéÈ   ÚOKú#Request fulfilled, document followséÉ   ÚCreatedúDocument created, URL followséÊ   ÚAcceptedú/Request accepted, processing continues off-lineéË   úNon-Authoritative InformationúRequest fulfilled from cacheéÌ   ú
No Contentú"Request fulfilled, nothing followséÍ   úReset Contentú"Clear input form for further inputéÎ   úPartial ContentúPartial content followséÏ   úMulti-StatuséÐ   úAlready Reportedéâ   úIM Usedé,  úMultiple Choicesú,Object has several resources -- see URI listé-  úMoved Permanentlyú(Object moved permanently -- see URI listé.  ÚFoundú(Object moved temporarily -- see URI listé/  ú	See Otherú'Object moved -- see Method and URL listé0  úNot Modifiedú)Document has not changed since given timeé1  ú	Use Proxyú@You must use proxy specified in Location to access this resourceé3  úTemporary Redirecté4  úPermanent Redirecté�  úBad Requestú(Bad request syntax or unsupported methodé‘  ÚUnauthorizedú*No permission -- see authorization schemesé’  úPayment Requiredú"No payment -- see charging schemesé“  Ú	Forbiddenú0Request forbidden -- authorization will not helpé”  ú	Not FoundúNothing matches the given URIé•  úMethod Not Allowedú-Specified method is invalid for this resourceé–  úNot Acceptableú%URI not available in preferred formaté—  úProxy Authentication Requiredú7You must authenticate with this proxy before proceedingé˜  úRequest Timeoutú"Request timed out; try again lateré™  ÚConflictúRequest conflictéš  ÚGoneú5URI no longer exists and has been permanently removedé›  úLength Requiredú"Client must specify Content-Lengthéœ  úPrecondition Failedú Precondition in headers is falseé�  úRequest Entity Too LargeúEntity is too largeéž  úRequest-URI Too LongúURI is too longéŸ  úUnsupported Media Typeú!Entity body in unsupported formaté   úRequested Range Not SatisfiableúCannot satisfy request rangeé¡  úExpectation Failedú'Expect condition could not be satisfiedé¦  úUnprocessable Entityé§  ÚLockedé¨  úFailed Dependencyéª  úUpgrade Requiredé¬  úPrecondition Requiredú8The origin server requires the request to be conditionalé­  úToo Many RequestsúOThe user has sent too many requests in a given amount of time ("rate limiting")é¯  úRequest Header Fields Too LargeúVThe server is unwilling to process the request because its header fields are too largeéô  úInternal Server ErrorúServer got itself in troubleéõ  úNot Implementedú&Server does not support this operationéö  úBad Gatewayú+Invalid responses from another server/proxyé÷  úService Unavailableú8The server cannot process the request due to a high loadéø  úGateway Timeoutú4The gateway server did not receive a timely responseéù  úHTTP Version Not SupportedúCannot fulfill requestéú  úVariant Also Negotiateséû  úInsufficient Storageéü  úLoop Detectedéþ  úNot Extendedéÿ  úNetwork Authentication Requiredú7The client needs to authenticate to gain network accessN)r   )r   r   r   )r   r   r   )r   r   )r   r   r   )r   r   r   )r   r   r   )r    r!   r"   )r#   r$   r%   )r&   r'   r(   )r)   r*   r+   )r,   r-   )r.   r/   )r0   r1   )r2   r3   r4   )r5   r6   r7   )r8   r9   r:   )r;   r<   r=   )r>   r?   r@   )rA   rB   rC   )rD   rE   r:   )rF   rG   r:   )rH   rI   rJ   )rK   rL   rM   )rN   rO   rP   )rQ   rR   rS   )rT   rU   rV   )rW   rX   rY   )rZ   r[   r\   )r]   r^   r_   )r`   ra   rb   )rc   rd   re   )rf   rg   rh   )ri   rj   rk   )rl   rm   rn   )ro   rp   rq   )rr   rs   rt   )ru   rv   rw   )rx   ry   rz   )r{   r|   r}   )r~   r   )r€   r�   )r‚   rƒ   )r„   r…   )r†   r‡   rˆ   )r‰   rŠ   r‹   )rŒ   r�   rŽ   )r�   r�   r‘   )r’   r“   r”   )r•   r–   r—   )r˜   r™   rš   )r›   rœ   r�   )rž   rŸ   r    )r¡   r¢   )r£   r¤   )r¥   r¦   )r§   r¨   )r©   rª   r«   )>Ú__name__Ú
__module__Ú__qualname__Ú__doc__r   ZCONTINUEZSWITCHING_PROTOCOLSZ
PROCESSINGr   ZCREATEDZACCEPTEDZNON_AUTHORITATIVE_INFORMATIONZ
NO_CONTENTZRESET_CONTENTZPARTIAL_CONTENTZMULTI_STATUSZALREADY_REPORTEDZIM_USEDZMULTIPLE_CHOICESZMOVED_PERMANENTLYZFOUNDZ	SEE_OTHERZNOT_MODIFIEDZ	USE_PROXYZTEMPORARY_REDIRECTZPERMANENT_REDIRECTZBAD_REQUESTZUNAUTHORIZEDZPAYMENT_REQUIREDZ	FORBIDDENZ	NOT_FOUNDZMETHOD_NOT_ALLOWEDZNOT_ACCEPTABLEZPROXY_AUTHENTICATION_REQUIREDZREQUEST_TIMEOUTZCONFLICTZGONEZLENGTH_REQUIREDZPRECONDITION_FAILEDZREQUEST_ENTITY_TOO_LARGEZREQUEST_URI_TOO_LONGZUNSUPPORTED_MEDIA_TYPEZREQUESTED_RANGE_NOT_SATISFIABLEZEXPECTATION_FAILEDZUNPROCESSABLE_ENTITYZLOCKEDZFAILED_DEPENDENCYZUPGRADE_REQUIREDZPRECONDITION_REQUIREDZTOO_MANY_REQUESTSZREQUEST_HEADER_FIELDS_TOO_LARGEZINTERNAL_SERVER_ERRORZNOT_IMPLEMENTEDZBAD_GATEWAYZSERVICE_UNAVAILABLEZGATEWAY_TIMEOUTZHTTP_VERSION_NOT_SUPPORTEDZVARIANT_ALSO_NEGOTIATESZINSUFFICIENT_STORAGEZLOOP_DETECTEDZNOT_EXTENDEDZNETWORK_AUTHENTICATION_REQUIREDr   r   r   r   r      sÆ   
	                                        N)Úenumr   Ú__all__r   r   r   r   r   Ú<module>   s   